Back to overview
NX Reports system maintenance
Apr 18, 2026 at 10:45pm UTC
Affected services
NX Portal
Resolved
Apr 20, 2026 at 3:21am UTC
NX Portal Reporting maintenance has been completed.
Affected services
Created
Apr 18, 2026 at 10:45pm UTC
We will be performing maintenance on NX Portal Reports throughout the weekend. Starting Saturday 4/18 at 4pm PDT through Sunday 4/19 at 10pm PDT.
Some report filtering may be inhibited during this time. We apologize for any inconvenience you may encounter.
NX POS Shift Summary reports will not be impacted.
Affected services