Back to overview
Potential TSYS Service interruption
Nov 08 at 06:06am HST
Affected services
NX Payment Gateway
Resolved
Nov 08 at 06:39am HST
Our payment partners have given an All Clear and the TSYS Platform is now performing as expected.
Affected services
Created
Nov 08 at 06:06am HST
We have been notified by our payment processing partners of a possible service disruption to the TSYS Platform.
We are monitoring the situation and will update the status board with information as we receive it.
Affected services