Back to overview
Resolved

NX Cloud Backend intermittent availability

Sep 1, 2026 at 7:22pm UTC
Affected services
NX Cloud Backend

Resolved
Sep 1, 2026 at 11:05pm UTC

All systems are operational and all data has been remediated.

Updated
Sep 1, 2026 at 9:16pm UTC

All services are showing green on the NX Cloud side. Backend remediation and syncing will take up to 4 hours to complete.
Once complete, we will mark this issue as resolved.

Updated
Sep 1, 2026 at 8:55pm UTC

Services are largely returning to normal operating status.

Updated
Sep 1, 2026 at 7:39pm UTC

Services are beginning to recover and most Cloud-level systems should be resuming normal operating functionality.

Created
Sep 1, 2026 at 7:22pm UTC

Some NX Cloud Backend services are experiencing intermittent availability. Our team is looking into the problem.

Next update 19:45 UTC